aboutsummaryrefslogtreecommitdiffstats
path: root/home/root/common/core/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/root/common/core/default.nix')
-rw-r--r--home/root/common/core/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/home/root/common/core/default.nix b/home/root/common/core/default.nix
new file mode 100644
index 0000000..2290509
--- /dev/null
+++ b/home/root/common/core/default.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, outputs, ... }:
+{
+ imports = [
+ ./bash.nix
+ ./git.nix
+ ./ssh.nix
+ ./tmux
+ ./vim
+ ./zsh
+ ];
+
+ home = {
+ username = lib.mkDefault "root";
+ homeDirectory = lib.mkDefault "/home/${config.home.username}";
+ stateVersion = lib.mkDefault "23.11";
+ };
+
+ #home.packages = builtins.attrValues {
+ # inherit (pkgs)
+ # wget
+ # zip;
+ #};
+
+ nix = {
+ package = lib.mkDefault pkgs.nix;
+ settings = {
+ experimental-features = [ "nix-command" "flakes" "repl-flake" ];
+ warn-dirty = false;
+ };
+ };
+
+ programs.home-manager.enable = true;
+}