aboutsummaryrefslogtreecommitdiffstats
path: root/home/root/common/core/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-04-18 19:28:29 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-04-18 19:28:29 -0700
commit0e741291f1ea350c398302e4b212a28f5c77840a (patch)
treefe86873dcb1168ba3e3644d7e300f6709d5b2503 /home/root/common/core/default.nix
parent05c88df33274373391b25fc73a1c965a74fb8d80 (diff)
downloadnix-0e741291f1ea350c398302e4b212a28f5c77840a.tar
nix-0e741291f1ea350c398302e4b212a28f5c77840a.tar.gz
nix-0e741291f1ea350c398302e4b212a28f5c77840a.tar.bz2
nix-0e741291f1ea350c398302e4b212a28f5c77840a.tar.lz
nix-0e741291f1ea350c398302e4b212a28f5c77840a.tar.xz
nix-0e741291f1ea350c398302e4b212a28f5c77840a.tar.zst
nix-0e741291f1ea350c398302e4b212a28f5c77840a.zip
Add root to home manager
Diffstat (limited to 'home/root/common/core/default.nix')
-rw-r--r--home/root/common/core/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/home/root/common/core/default.nix b/home/root/common/core/default.nix
new file mode 100644
index 0000000..2290509
--- /dev/null
+++ b/home/root/common/core/default.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, outputs, ... }:
+{
+ imports = [
+ ./bash.nix
+ ./git.nix
+ ./ssh.nix
+ ./tmux
+ ./vim
+ ./zsh
+ ];
+
+ home = {
+ username = lib.mkDefault "root";
+ homeDirectory = lib.mkDefault "/home/${config.home.username}";
+ stateVersion = lib.mkDefault "23.11";
+ };
+
+ #home.packages = builtins.attrValues {
+ # inherit (pkgs)
+ # wget
+ # zip;
+ #};
+
+ nix = {
+ package = lib.mkDefault pkgs.nix;
+ settings = {
+ experimental-features = [ "nix-command" "flakes" "repl-flake" ];
+ warn-dirty = false;
+ };
+ };
+
+ programs.home-manager.enable = true;
+}