aboutsummaryrefslogtreecommitdiffstats
path: root/home/root/arrakis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/root/arrakis.nix')
-rw-r--r--home/root/arrakis.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/home/root/arrakis.nix b/home/root/arrakis.nix
index ac7a30a..47c9552 100644
--- a/home/root/arrakis.nix
+++ b/home/root/arrakis.nix
@@ -5,6 +5,7 @@
];
home.file = {
+ "bin/knock".source = ../common/scripts/knock;
"bin/vpnctl" = {
executable = true;
text = ''
@@ -86,4 +87,15 @@
nix.extraOptions = ''
!include /run/secrets/nix-access-token-github
'';
+
+ sops = {
+ age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
+ defaultSopsFile = ./secrets/arrakis.yaml;
+
+ secrets = {
+ "ssh_config" = {
+ path = "/root/.ssh/config";
+ };
+ };
+ };
}