aboutsummaryrefslogtreecommitdiffstats
path: root/home/root/arrakis.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2025-03-18 13:05:35 -0700
committerMark Nipper <nipsy@bitgnome.net>2025-03-18 13:05:35 -0700
commit1cb48d9853ca809e1ecb8bc179e2667e682e2199 (patch)
treed03d4418350f4bef5310a5a6d7f635046d2d6119 /home/root/arrakis.nix
parentf85a514d168061b044d59f2ecc162a4cd5a03c26 (diff)
downloadnix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar.gz
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar.bz2
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar.lz
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar.xz
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.tar.zst
nix-1cb48d9853ca809e1ecb8bc179e2667e682e2199.zip
Add SSH configuration for root@arrakis
Diffstat (limited to 'home/root/arrakis.nix')
-rw-r--r--home/root/arrakis.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/home/root/arrakis.nix b/home/root/arrakis.nix
index ac7a30a..47c9552 100644
--- a/home/root/arrakis.nix
+++ b/home/root/arrakis.nix
@@ -5,6 +5,7 @@
];
home.file = {
+ "bin/knock".source = ../common/scripts/knock;
"bin/vpnctl" = {
executable = true;
text = ''
@@ -86,4 +87,15 @@
nix.extraOptions = ''
!include /run/secrets/nix-access-token-github
'';
+
+ sops = {
+ age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
+ defaultSopsFile = ./secrets/arrakis.yaml;
+
+ secrets = {
+ "ssh_config" = {
+ path = "/root/.ssh/config";
+ };
+ };
+ };
}