aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-02-27 00:25:18 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-02-27 00:25:18 -0800
commite97acf6b51a17c35c950de712f71f85be48a59fe (patch)
treecf13db15b19555ff9d6e3751bea8a9b0e362a225 /ginaz/configuration.nix
parente0d45a7f4537d8b2478df1e0de9ce84c81c9fc64 (diff)
downloadnix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar.gz
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar.bz2
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar.lz
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar.xz
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.tar.zst
nix-e97acf6b51a17c35c950de712f71f85be48a59fe.zip
Switch ginaz to unstable and fix initial configuration
Diffstat (limited to 'ginaz/configuration.nix')
-rw-r--r--ginaz/configuration.nix83
1 files changed, 77 insertions, 6 deletions
diff --git a/ginaz/configuration.nix b/ginaz/configuration.nix
index 9dd7e6a..ac85c26 100644
--- a/ginaz/configuration.nix
+++ b/ginaz/configuration.nix
@@ -19,6 +19,7 @@
boot.supportedFilesystems = [ "zfs" ];
boot.zfs.devNodes = "/dev/disk/by-label";
+ documentation.dev.enable = true;
documentation.man.enable = true;
environment.shells = with pkgs; [ zsh ];
@@ -26,9 +27,26 @@
# $ nix search wget
environment.systemPackages = with pkgs; [
curl
+ dmenu
+ feh
+ geeqie
+ git
i3
+ i3status
+ netcat-openbsd
+ pass
+ passExtensions.pass-otp
+ pavucontrol
+ polkit_gnome
+ reaper
+ signal-desktop
+ st
+ stoken
vim
wget
+ xdotool
+ xorg.xdpyinfo
+ xscreensaver
];
i18n.defaultLocale = "en_US.UTF-8";
@@ -36,6 +54,7 @@
networking.hostId = "8425e349";
networking.hostName = "ginaz";
networking.networkmanager.enable = true;
+ networking.nftables.enable = true;
nixpkgs.config.allowUnfree = true;
@@ -52,8 +71,28 @@
programs.tmux.enable = true;
programs.zsh.enable = true;
+ security.polkit = {
+ enable = true;
+ extraConfig = ''
+ polkit.addRule(function(action, subject) {
+ if (
+ subject.isInGroup("users")
+ && (
+ action.id == "org.freedesktop.login1.reboot" ||
+ action.id == "org.freedesktop.login1.reboot-multiple-sessions" ||
+ action.id == "org.freedesktop.login1.power-off" ||
+ action.id == "org.freedesktop.login1.power-off-multiple-sessions"
+ )
+ )
+ {
+ return polkit.Result.YES;
+ }
+ })
+ '';
+ };
security.rtkit.enable = true;
+ services.blueman.enable = true;
services.openssh = {
enable = true;
settings.PasswordAuthentication = false;
@@ -68,17 +107,46 @@
jack.enable = true;
};
services.printing.enable = true;
- services.xserver.displayManager.lightdm.enable = true;
- services.xserver.enable = true;
- services.xserver.libinput.enable = true;
- services.xserver.xkb.layout = "us";
- services.xserver.xkb.options = "caps:super,compose:ralt";
+ services.xserver = {
+ displayManager.defaultSession = "xsession";
+ displayManager.lightdm = {
+ enable = true;
+ extraSeatDefaults = ''greeter-hide-users=true'';
+ };
+ displayManager.session = [
+ {
+ manage = "desktop";
+ name = "xsession";
+ start = ''exec $HOME/.xsession'';
+ }
+ ];
+ enable = true;
+ libinput.enable = true;
+ xkb.layout = "us";
+ xkb.options = "caps:super,compose:ralt";
+ };
services.zfs.autoScrub.enable = true;
services.zfs.trim.enable = true;
system.copySystemConfiguration = true;
system.stateVersion = "23.11";
+ systemd = {
+ user.services.polkit-gnome-authentication-agent-1 = {
+ description = "polkit-gnome-authentication-agent-1";
+ wantedBy = [ "graphical-session.target" ];
+ wants = [ "graphical-session.target" ];
+ after = [ "graphical-session.target" ];
+ serviceConfig = {
+ Type = "simple";
+ ExecStart = "${pkgs.polkit_gnome}/libexec/polkit-gnome-authentication-agent-1";
+ Restart = "on-failure";
+ RestartSec = 1;
+ TimeoutStopSec = 10;
+ };
+ };
+ };
+
time.timeZone = "America/Los_Angeles";
users.groups.nipsy.gid = 1000;
@@ -96,5 +164,8 @@
openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
};
- users.users.root.openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
+ users.users.root = {
+ shell = pkgs.zsh;
+ openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
+ };
}