aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-02-26 16:38:17 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-02-26 16:38:17 -0800
commite0d45a7f4537d8b2478df1e0de9ce84c81c9fc64 (patch)
treeb62117bc0aadecf2c2470ad1df957673356d85aa /ginaz/configuration.nix
parent931658a79bb5a76e9d1d64bf0f09b8629c9083b1 (diff)
downloadnix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar.gz
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar.bz2
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar.lz
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar.xz
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.tar.zst
nix-e0d45a7f4537d8b2478df1e0de9ce84c81c9fc64.zip
Add some packages
Diffstat (limited to 'ginaz/configuration.nix')
-rw-r--r--ginaz/configuration.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/ginaz/configuration.nix b/ginaz/configuration.nix
index 32259fa..9dd7e6a 100644
--- a/ginaz/configuration.nix
+++ b/ginaz/configuration.nix
@@ -19,12 +19,13 @@
boot.supportedFilesystems = [ "zfs" ];
boot.zfs.devNodes = "/dev/disk/by-label";
+ documentation.man.enable = true;
+
environment.shells = with pkgs; [ zsh ];
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
curl
- firefox
i3
vim
wget
@@ -36,13 +37,19 @@
networking.hostName = "ginaz";
networking.networkmanager.enable = true;
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- programs.mtr.enable = true;
+ nixpkgs.config.allowUnfree = true;
+
+ programs.atop.enable = true;
+ programs.firefox.enable = true;
programs.gnupg.agent = {
enable = true;
enableSSHSupport = true;
};
+ programs.iftop.enable = true;
+ programs.mtr.enable = true;
+ programs.nm-applet.enable = true;
+ programs.steam.enable = true;
+ programs.tmux.enable = true;
programs.zsh.enable = true;
security.rtkit.enable = true;