aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-02-26 15:53:49 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-02-26 15:53:49 -0800
commit931658a79bb5a76e9d1d64bf0f09b8629c9083b1 (patch)
tree7ed5eac400e11d81e08523f35c28fb2fbcbb0d72 /ginaz/configuration.nix
downloadnix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.gz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.bz2
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.lz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.xz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.zst
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.zip
Add initial NixOS configuration for ginaz
Diffstat (limited to 'ginaz/configuration.nix')
-rw-r--r--ginaz/configuration.nix93
1 files changed, 93 insertions, 0 deletions
diff --git a/ginaz/configuration.nix b/ginaz/configuration.nix
new file mode 100644
index 0000000..32259fa
--- /dev/null
+++ b/ginaz/configuration.nix
@@ -0,0 +1,93 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page, on
+# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
+
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ./hardware-configuration.nix
+ ];
+
+ boot.initrd.kernelModules = [ "zfs" ];
+ #boot.initrd.postDeviceCommands = ''zpool import -lf rpool'';
+ boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.loader.generationsDir.copyKernels = true;
+ boot.loader.systemd-boot.enable = true;
+ boot.supportedFilesystems = [ "zfs" ];
+ boot.zfs.devNodes = "/dev/disk/by-label";
+
+ environment.shells = with pkgs; [ zsh ];
+ # List packages installed in system profile. To search, run:
+ # $ nix search wget
+ environment.systemPackages = with pkgs; [
+ curl
+ firefox
+ i3
+ vim
+ wget
+ ];
+
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ networking.hostId = "8425e349";
+ networking.hostName = "ginaz";
+ networking.networkmanager.enable = true;
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ programs.mtr.enable = true;
+ programs.gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
+ programs.zsh.enable = true;
+
+ security.rtkit.enable = true;
+
+ services.openssh = {
+ enable = true;
+ settings.PasswordAuthentication = false;
+ settings.KbdInteractiveAuthentication = false;
+ settings.PermitRootLogin = "yes";
+ };
+ services.pipewire = {
+ enable = true;
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+ jack.enable = true;
+ };
+ services.printing.enable = true;
+ services.xserver.displayManager.lightdm.enable = true;
+ services.xserver.enable = true;
+ services.xserver.libinput.enable = true;
+ services.xserver.xkb.layout = "us";
+ services.xserver.xkb.options = "caps:super,compose:ralt";
+ services.zfs.autoScrub.enable = true;
+ services.zfs.trim.enable = true;
+
+ system.copySystemConfiguration = true;
+ system.stateVersion = "23.11";
+
+ time.timeZone = "America/Los_Angeles";
+
+ users.groups.nipsy.gid = 1000;
+ users.users.nipsy = {
+ isNormalUser = true;
+ group = "nipsy";
+ home = "/home/nipsy";
+ description = "Mark Nipper";
+ extraGroups = [ "wheel" "networkmanager" ];
+ #packages = with pkgs; [
+ # firefox
+ # tree
+ #];
+ shell = pkgs.zsh;
+ openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
+ };
+
+ users.users.root.openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
+}