aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/richese/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/richese/default.nix')
-rw-r--r--hosts/richese/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/hosts/richese/default.nix b/hosts/richese/default.nix
index d612b07..e2c37d5 100644
--- a/hosts/richese/default.nix
+++ b/hosts/richese/default.nix
@@ -38,6 +38,15 @@
config.allowUnfree = true;
hostPlatform = "x86_64-linux";
overlays = [
+ (final: prev: {
+ pythonPackagesExtensions = prev.pythonPackagesExtensions ++ [(
+ python-final: python-prev: {
+ openstackclient-full = python-prev.openstackclient-full.overridePythonAttrs (oldAttrs: {
+ dependencies = oldAttrs.dependencies ++ [ pkgs.python311Packages.pysocks ];
+ });
+ }
+ )];
+ })
outputs.overlays.additions
outputs.overlays.modifications
outputs.overlays.master-packages