aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/kaitain/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kaitain/default.nix')
-rw-r--r--hosts/kaitain/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/hosts/kaitain/default.nix b/hosts/kaitain/default.nix
new file mode 100644
index 0000000..b83a2c1
--- /dev/null
+++ b/hosts/kaitain/default.nix
@@ -0,0 +1,57 @@
+{ config, lib, pkgs, ... }: {
+ boot = {
+ initrd.kernelModules = [ "zfs" ];
+ kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ loader.grub.device = "/dev/sda";
+ supportedFilesystems = [ "zfs" ];
+ #zfs.devNodes = "/dev/disk/by-label";
+ };
+
+ environment.systemPackages = with pkgs; [
+ git-review
+ ];
+
+ imports = [
+ ./hardware-configuration.nix
+ ../common/core
+ #../common/optional/db.nix
+ ../common/optional/dev.nix
+ ../common/optional/misc.nix
+ #../common/optional/multimedia.nix
+ ../common/optional/pipewire.nix
+ ../common/optional/services/openssh.nix
+ ../common/optional/services/xorg.nix
+ ../common/optional/zfs.nix
+ ../common/users/nipsy
+ ../common/users/root
+ ];
+
+ networking = {
+ hostId = "4b1f6e29";
+ hostName = "kaitain";
+ nftables.enable = true;
+ };
+
+ services.xserver.videoDrivers = lib.mkForce [ "vmware" "virtualbox" "modesetting" ];
+
+ system.stateVersion = "23.11";
+
+ #systemd.user.services = let
+ # vbox-client = desc: flags: {
+ # description = "VirtualBox Guest: ${desc}";
+
+ # wantedBy = [ "graphical-session.target" ];
+ # requires = [ "dev-vboxguest.device" ];
+ # after = [ "dev-vboxguest.device" ];
+
+ # unitConfig.ConditionVirtualization = "oracle";
+
+ # serviceConfig.ExecStart = "${config.boot.kernelPackages.virtualboxGuestAdditions}/bin/VBoxClient -fv ${flags}";
+ # };
+ #in {
+ # virtualbox-resize = vbox-client "Resize" "--vmsvga";
+ # virtualbox-clipboard = vbox-client "Clipboard" "--clipboard";
+ #};
+
+ virtualisation.virtualbox.guest.enable = true;
+}