aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/darkstar/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/darkstar/hardware-configuration.nix')
-rw-r--r--hosts/darkstar/hardware-configuration.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/hosts/darkstar/hardware-configuration.nix b/hosts/darkstar/hardware-configuration.nix
index 49cc244..d4a76e7 100644
--- a/hosts/darkstar/hardware-configuration.nix
+++ b/hosts/darkstar/hardware-configuration.nix
@@ -13,51 +13,5 @@
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
- fileSystems."/" =
- { device = "rpool/local/root";
- fsType = "zfs";
- };
-
- fileSystems."/efiboot/efi1" =
- { device = "/dev/disk/by-label/ESP1";
- fsType = "vfat";
- options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
- };
-
- fileSystems."/efiboot/efi2" =
- { device = "/dev/disk/by-label/ESP2";
- fsType = "vfat";
- options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
- };
-
- fileSystems."/nix" =
- { device = "rpool/local/nix";
- fsType = "zfs";
- };
-
- fileSystems."/root" =
- { device = "rpool/user/home/root";
- fsType = "zfs";
- };
-
- fileSystems."/home/nipsy" =
- { device = "rpool/user/home/nipsy";
- fsType = "zfs";
- };
-
- swapDevices =
- [ { device = "/dev/disk/by-label/swap1"; }
- { device = "/dev/disk/by-label/swap2"; }
- ];
-
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp116s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp117s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
-
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}