aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/common/optional/services/dhcp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/optional/services/dhcp.nix')
-rw-r--r--hosts/common/optional/services/dhcp.nix36
1 files changed, 18 insertions, 18 deletions
diff --git a/hosts/common/optional/services/dhcp.nix b/hosts/common/optional/services/dhcp.nix
index 3eed193..2547bf9 100644
--- a/hosts/common/optional/services/dhcp.nix
+++ b/hosts/common/optional/services/dhcp.nix
@@ -3,13 +3,13 @@
environment = {
etc = {
- "tftp/ipxe.efi".source = "${pkgs.ipxe}/ipxe.efi";
- "tftp/undionly.kpxe".source = "${pkgs.ipxe}/undionly.kpxe";
+ #"tftp/ipxe.efi".source = "${pkgs.ipxe}/ipxe.efi";
+ #"tftp/undionly.kpxe".source = "${pkgs.ipxe}/undionly.kpxe";
};
systemPackages = with pkgs; [
ipxe
- tftp-hpa
+ #tftp-hpa
wol
];
};
@@ -114,20 +114,20 @@
};
systemd.services = {
- tftpd = {
- after = [ "nftables.service" ];
- description = "TFTP server";
- serviceConfig = {
- User = "root";
- Group = "root";
- Restart = "always";
- RestartSec = 5;
- Type = "exec";
- ExecStart = "${pkgs.tftp-hpa}/bin/in.tftpd -l -a 192.168.1.1:69 -P /run/tftpd.pid /etc/tftp";
- TimeoutStopSec = 20;
- PIDFile = "/run/tftpd.pid";
- };
- wantedBy = [ "multi-user.target" ];
- };
+ #tftpd = {
+ # after = [ "nftables.service" ];
+ # description = "TFTP server";
+ # serviceConfig = {
+ # User = "root";
+ # Group = "root";
+ # Restart = "always";
+ # RestartSec = 5;
+ # Type = "exec";
+ # ExecStart = "${pkgs.tftp-hpa}/bin/in.tftpd -l -a 192.168.1.1:69 -P /run/tftpd.pid /etc/tftp";
+ # TimeoutStopSec = 20;
+ # PIDFile = "/run/tftpd.pid";
+ # };
+ # wantedBy = [ "multi-user.target" ];
+ #};
};
}