aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/arrakis/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/arrakis/default.nix')
-rw-r--r--hosts/arrakis/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/hosts/arrakis/default.nix b/hosts/arrakis/default.nix
index 19918b7..9fda650 100644
--- a/hosts/arrakis/default.nix
+++ b/hosts/arrakis/default.nix
@@ -1,6 +1,6 @@
{ config, inputs, outputs, pkgs, ... }: {
boot = {
- initrd.kernelModules = [ "zfs" ];
+ initrd.kernelModules = [ "amdgpu" "zfs" ];
kernel.sysctl = {
"net.ipv4.ip_forward" = 1;
"net.ipv4.conf.all.proxy_arp" = 1;
@@ -226,7 +226,7 @@
};
hostPlatform = "x86_64-linux";
overlays = [
- inputs.nvidia-patch.overlays.default
+ #inputs.nvidia-patch.overlays.default
outputs.overlays.additions
outputs.overlays.modifications
outputs.overlays.master-packages
@@ -236,7 +236,7 @@
};
services.openssh.settings.X11Forwarding = true;
- services.xserver.videoDrivers = [ "nvidia" ];
+ services.xserver.videoDrivers = [ "amdgpu" ];
sops = {
age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];