aboutsummaryrefslogtreecommitdiffstats
path: root/home/root/arrakis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/root/arrakis.nix')
-rw-r--r--home/root/arrakis.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/root/arrakis.nix b/home/root/arrakis.nix
index c78c958..f7600df 100644
--- a/home/root/arrakis.nix
+++ b/home/root/arrakis.nix
@@ -72,4 +72,17 @@
'';
};
};
+
+ nix.extraOptions = ''
+ !include ${config.sops.secrets."nix-access-token-github".path}
+ '';
+
+ sops = {
+ age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
+ defaultSopsFile = ./secrets/arrakis.yaml;
+
+ secrets = {
+ "nix-access-token-github" = {};
+ };
+ };
}