aboutsummaryrefslogtreecommitdiffstats
path: root/home/don/common/core/bash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/don/common/core/bash.nix')
-rw-r--r--home/don/common/core/bash.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/home/don/common/core/bash.nix b/home/don/common/core/bash.nix
index 77f0cf4..7bfb808 100644
--- a/home/don/common/core/bash.nix
+++ b/home/don/common/core/bash.nix
@@ -3,8 +3,14 @@
enable = true;
enableCompletion = true;
shellAliases = {
- ll = "ls -alF --color=auto";
+ grep = "grep --color=auto";
+ ip = "ip -c=auto";
la = "ls -aF --color=auto";
+ ll = "ls -alF --color=auto";
+ lock = "xscreensaver-command -lock";
+ nix-list-derivations = "nix-store --query --requisites /run/current-system | cut -d- -f2- | sort | uniq";
+ nix-list-generations = "nixos-rebuild list-generations";
+ zgrep = "zgrep --color=auto";
};
};
}