aboutsummaryrefslogtreecommitdiffstats
path: root/home/don/common/core/bash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/don/common/core/bash.nix')
-rw-r--r--home/don/common/core/bash.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/home/don/common/core/bash.nix b/home/don/common/core/bash.nix
new file mode 100644
index 0000000..7bfb808
--- /dev/null
+++ b/home/don/common/core/bash.nix
@@ -0,0 +1,16 @@
+{
+ programs.bash = {
+ enable = true;
+ enableCompletion = true;
+ shellAliases = {
+ grep = "grep --color=auto";
+ ip = "ip -c=auto";
+ la = "ls -aF --color=auto";
+ ll = "ls -alF --color=auto";
+ lock = "xscreensaver-command -lock";
+ nix-list-derivations = "nix-store --query --requisites /run/current-system | cut -d- -f2- | sort | uniq";
+ nix-list-generations = "nixos-rebuild list-generations";
+ zgrep = "zgrep --color=auto";
+ };
+ };
+}