aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index fee0488..e263287 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,11 +23,6 @@
nixpkgs-stable.url = "github:nixos/nixpkgs/release-24.05";
nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
- nvidia-patch = {
- url = "github:icewind1991/nvidia-patch-nixos";
- inputs.nixpkgs.follows = "nixpkgs-unstable";
- };
-
sops-nix = {
url = "github:Mic92/sops-nix";
inputs.nixpkgs.follows = "nixpkgs-unstable";
@@ -35,14 +30,14 @@
};
- outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, nvidia-patch, sops-nix, ... }: {
+ outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: {
nixosConfigurations = {
arrakis = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
- specialArgs = { inherit inputs nvidia-patch;
+ specialArgs = {
pkgs = import nixpkgs-unstable {
inherit system;
config.allowUnfree = true;