aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 4bd26e6..7f94a22 100644
--- a/flake.nix
+++ b/flake.nix
@@ -88,6 +88,22 @@
];
};
+ # from https://nixos.wiki/wiki/Creating_a_NixOS_live_CD and https://chengeric.com/homelab/
+ iso = nixpkgs.lib.nixosSystem {
+ modules = [
+ "${nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix"
+ ({
+ #isoImage.squashfsCompression = "gzip -Xcompression-level 1";
+ users.users.nixos = {
+ openssh.authorizedKeys.keys = [
+ (builtins.readFile ./hosts/common/users/nipsy/keys/id_arrakis.pub)
+ ];
+ };
+ })
+ ];
+ system = "x86_64-linux";
+ };
+
kaitain = nixpkgs.lib.nixosSystem rec {
specialArgs = { inherit inputs outputs; };
modules = [