diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -23,6 +23,11 @@ nixpkgs-stable.url = "github:nixos/nixpkgs/release-24.05"; nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable"; + nvidia-patch = { + url = "github:icewind1991/nvidia-patch-nixos"; + inputs.nixpkgs.follows = "nixpkgs-unstable"; + }; + sops-nix = { url = "github:Mic92/sops-nix"; inputs.nixpkgs.follows = "nixpkgs-unstable"; @@ -30,14 +35,14 @@ }; - outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: { + outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, nvidia-patch, sops-nix, ... }: { nixosConfigurations = { arrakis = nixpkgs-unstable.lib.nixosSystem rec { system = "x86_64-linux"; - specialArgs = { + specialArgs = { inherit inputs; pkgs = import nixpkgs-unstable { inherit system; config.allowUnfree = true; |