aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-10-21 09:00:44 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-10-21 09:00:44 -0700
commit37cfe1d6abd3d76fcec15b736b737ca859ff08a3 (patch)
treef858c5bae685af64f8ea05bca5ff076b48733c72 /flake.nix
parent6d0423c4914cf409184d78d34f59aafa0d702bdb (diff)
downloadnix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar.gz
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar.bz2
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar.lz
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar.xz
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.tar.zst
nix-37cfe1d6abd3d76fcec15b736b737ca859ff08a3.zip
Add nVidia patches
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index e263287..5de9011 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,6 +23,11 @@
nixpkgs-stable.url = "github:nixos/nixpkgs/release-24.05";
nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
+ nvidia-patch = {
+ url = "github:icewind1991/nvidia-patch-nixos";
+ inputs.nixpkgs.follows = "nixpkgs-unstable";
+ };
+
sops-nix = {
url = "github:Mic92/sops-nix";
inputs.nixpkgs.follows = "nixpkgs-unstable";
@@ -30,14 +35,14 @@
};
- outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: {
+ outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, nvidia-patch, sops-nix, ... }: {
nixosConfigurations = {
arrakis = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
- specialArgs = {
+ specialArgs = { inherit inputs;
pkgs = import nixpkgs-unstable {
inherit system;
config.allowUnfree = true;