aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix100
1 files changed, 76 insertions, 24 deletions
diff --git a/flake.nix b/flake.nix
index ef8e092..e263287 100644
--- a/flake.nix
+++ b/flake.nix
@@ -30,14 +30,26 @@
};
- outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: rec {
+ outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: {
nixosConfigurations = {
- arrakis = nixpkgs-unstable.lib.nixosSystem {
- pkgs = pkgs-unstable;
- #specialArgs = { inherit inputs; };
+ arrakis = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
+
+ specialArgs = {
+ pkgs = import nixpkgs-unstable {
+ inherit system;
+ config.allowUnfree = true;
+ overlays = [(import ./pkgs)];
+ };
+
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ };
+
modules = [
./hosts/arrakis
home-manager-unstable.nixosModules.home-manager {
@@ -49,10 +61,22 @@
];
};
- darkstar = nixpkgs-unstable.lib.nixosSystem {
- pkgs = pkgs-unstable;
- #specialArgs = { inherit inputs; };
+ darkstar = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
+
+ specialArgs = {
+ pkgs = import nixpkgs-unstable {
+ inherit system;
+ config.allowUnfree = true;
+ overlays = [(import ./pkgs)];
+ };
+
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ };
+
modules = [
./hosts/darkstar
home-manager-unstable.nixosModules.home-manager {
@@ -63,10 +87,22 @@
];
};
- ginaz = nixpkgs-unstable.lib.nixosSystem {
- pkgs = pkgs-unstable;
- #specialArgs = { inherit inputs; };
+ ginaz = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
+
+ specialArgs = {
+ pkgs = import nixpkgs-unstable {
+ inherit system;
+ config.allowUnfree = true;
+ overlays = [(import ./pkgs)];
+ };
+
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ };
+
modules = [
./hosts/ginaz
home-manager-unstable.nixosModules.home-manager {
@@ -79,9 +115,22 @@
];
};
- kaitain = nixpkgs-unstable.lib.nixosSystem {
- pkgs = pkgs-unstable;
+ kaitain = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
+
+ specialArgs = {
+ pkgs = import nixpkgs-unstable {
+ inherit system;
+ config.allowUnfree = true;
+ overlays = [(import ./pkgs)];
+ };
+
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ };
+
modules = [
./hosts/kaitain
home-manager-unstable.nixosModules.home-manager {
@@ -91,9 +140,22 @@
];
};
- richese = nixpkgs-unstable.lib.nixosSystem {
- pkgs = pkgs-unstable;
+ richese = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
+
+ specialArgs = {
+ pkgs = import nixpkgs-unstable {
+ inherit system;
+ config.allowUnfree = true;
+ overlays = [(import ./pkgs)];
+ };
+
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ };
+
modules = [
./hosts/richese
home-manager-unstable.nixosModules.home-manager {
@@ -102,19 +164,9 @@
}
];
};
- };
- pkgs-stable = import nixpkgs-stable {
- system = "x86_64-linux";
- config.allowUnfree = true;
- overlays = [(import ./pkgs)];
};
- pkgs-unstable = import nixpkgs-unstable {
- system = "x86_64-linux";
- config.allowUnfree = true;
- overlays = [(import ./pkgs)];
- };
};
}