aboutsummaryrefslogtreecommitdiffstats
path: root/overlays/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-10-23 02:04:51 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-10-23 02:04:51 -0700
commitf95e8c631c1f45249b716c5cf106c891be7d6c24 (patch)
tree7f3774068918b504cd19bfe1a860a5f1245e520d /overlays/default.nix
parentf03eaf57c08a9ee942e84666663458d7b437a408 (diff)
downloadnix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar.gz
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar.bz2
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar.lz
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar.xz
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.tar.zst
nix-f95e8c631c1f45249b716c5cf106c891be7d6c24.zip
Migrate to more standard flake template
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
new file mode 100644
index 0000000..c39804a
--- /dev/null
+++ b/overlays/default.nix
@@ -0,0 +1,23 @@
+# This file defines overlays
+{inputs, ...}: {
+ # This one brings our custom packages from the 'pkgs' directory
+ additions = final: _prev: import ../pkgs final.pkgs;
+
+ # This one contains whatever you want to overlay
+ # You can change versions, add patches, set compilation flags, anything really.
+ # https://nixos.wiki/wiki/Overlays
+ modifications = final: prev: {
+ # example = prev.example.overrideAttrs (oldAttrs: rec {
+ # ...
+ # });
+ };
+
+ # When applied, the stable nixpkgs set (declared in the flake inputs) will
+ # be accessible through 'pkgs.stable'
+ stable-packages = final: _prev: {
+ stable = import inputs.nixpkgs-stable {
+ system = final.system;
+ config.allowUnfree = true;
+ };
+ };
+}