aboutsummaryrefslogtreecommitdiffstats
path: root/overlays/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-04-11 01:37:43 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-04-11 01:37:43 -0700
commit3a44b124561f544c229c0042cd0b91d055a33409 (patch)
treef466af390e895799192268a45f2516517487d672 /overlays/default.nix
parent40d73be8797434f7a6e124ce64ae38cd28a06fd0 (diff)
downloadnix-3a44b124561f544c229c0042cd0b91d055a33409.tar
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.gz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.bz2
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.lz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.xz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.zst
nix-3a44b124561f544c229c0042cd0b91d055a33409.zip
Add work VM and redo entire flake layout
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
deleted file mode 100644
index 669bd73..0000000
--- a/overlays/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# This file defines overlays/custom modifications to upstream packages
-#
-
-{ inputs, ... }: {
- # This one brings our custom packages from the 'pkgs' directory
- additions = final: _prev: import ../pkgs { pkgs = final; };
-
- # This one contains whatever you want to overlay
- # You can change versions, add patches, set compilation flags, anything really.
- # https://nixos.wiki/wiki/Overlays
- modifications = final: prev: {
- # example = prev.example.overrideAttrs (oldAttrs: let ... in {
- # ...
- # });
- };
-
- # When applied, the unstable nixpkgs set (declared in the flake inputs) will
- # be accessible through 'pkgs.unstable'
- unstable-packages = final: _prev: {
- unstable = import inputs.nixpkgs-unstable {
- system = final.system;
- config.allowUnfree = true;
- };
- };
-}