aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/uranus/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-11 19:05:02 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-11 19:05:02 -0800
commitcb3885e72abaa985e0e1fd95f6e57382c7c343e7 (patch)
tree04fe914816b35de2a2e6a9d7eef2b1e296490492 /hosts/uranus/hardware-configuration.nix
parent2f0664317ee6b6dd9bd05844582346b0b6fec1b8 (diff)
downloadnix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.gz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.bz2
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.lz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.xz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.zst
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.zip
Add @uranus
Diffstat (limited to 'hosts/uranus/hardware-configuration.nix')
-rw-r--r--hosts/uranus/hardware-configuration.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/hosts/uranus/hardware-configuration.nix b/hosts/uranus/hardware-configuration.nix
new file mode 100644
index 0000000..96dd160
--- /dev/null
+++ b/hosts/uranus/hardware-configuration.nix
@@ -0,0 +1,47 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ #(modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "rpool/local/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-label/boot";
+ fsType = "vfat";
+ };
+
+ fileSystems."/nix" =
+ { device = "rpool/local/nix";
+ fsType = "zfs";
+ };
+
+ fileSystems."/root" =
+ { device = "rpool/user/home/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home/nipsy" =
+ { device = "rpool/user/home/nipsy";
+ fsType = "zfs";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-label/swap"; }
+ ];
+
+ #nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ #hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}