aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/saturn/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-12 00:03:55 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-12 00:03:55 -0800
commit7968deab695be4d5eaadfc81d2413f61d82ee777 (patch)
tree5912519fdc4eb07d26d48ee0e69c05d271c17347 /hosts/saturn/default.nix
parent796fcbfd3b9c2de166ada6d317c6f041914e66ec (diff)
downloadnix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.gz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.bz2
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.lz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.xz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.zst
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.zip
Add @neptune @saturn
Diffstat (limited to 'hosts/saturn/default.nix')
-rw-r--r--hosts/saturn/default.nix67
1 files changed, 67 insertions, 0 deletions
diff --git a/hosts/saturn/default.nix b/hosts/saturn/default.nix
new file mode 100644
index 0000000..bca97f0
--- /dev/null
+++ b/hosts/saturn/default.nix
@@ -0,0 +1,67 @@
+{ config, inputs, outputs, pkgs, ... }: {
+ boot = {
+ initrd.kernelModules = [ "amdgpu" "zfs" ];
+ #kernel.sysctl = {
+ # "net.ipv4.ip_forward" = true;
+ #};
+ loader = {
+ efi.canTouchEfiVariables = true;
+ systemd-boot.enable = true;
+ timeout = 3;
+ };
+ supportedFilesystems = [ "zfs" ];
+ zfs.devNodes = "/dev/disk/by-label";
+ };
+
+ environment.systemPackages = with pkgs; [
+ wpa_supplicant
+ ];
+
+ imports = [
+ ./disks.nix
+ ./hardware-configuration.nix
+ ../common/core
+ ../common/optional/misc.nix
+ ../common/optional/services/fwupd.nix
+ ../common/optional/services/openssh.nix
+ ../common/optional/zfs.nix
+ ../common/users/nipsy
+ ../common/users/root
+ ];
+
+ networking = {
+ hostId = "4ae5eb4d";
+ hostName = "saturn";
+ domain = "bitgnome.net";
+ nftables.enable = true;
+ wireless = {
+ enable = true;
+ userControlled.enable = true;
+ };
+ };
+
+ nixpkgs = {
+ config.allowUnfree = true;
+ hostPlatform = "x86_64-linux";
+ overlays = [
+ outputs.overlays.additions
+ outputs.overlays.modifications
+ outputs.overlays.master-packages
+ outputs.overlays.stable-packages
+ ];
+ };
+
+ #sops = {
+ # age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
+ # defaultSopsFile = ../secrets/saturn.yaml;
+
+ # secrets = {
+ # "kea-dhcp4_conf" = {};
+ # "nftables/forward" = {};
+ # "nftables/ssh" = {};
+ # "nix-access-token-github" = {};
+ # };
+ #};
+
+ system.stateVersion = "24.11";
+}