aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/richese/disks.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-04-11 01:37:43 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-04-11 01:37:43 -0700
commit3a44b124561f544c229c0042cd0b91d055a33409 (patch)
treef466af390e895799192268a45f2516517487d672 /hosts/richese/disks.nix
parent40d73be8797434f7a6e124ce64ae38cd28a06fd0 (diff)
downloadnix-3a44b124561f544c229c0042cd0b91d055a33409.tar
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.gz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.bz2
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.lz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.xz
nix-3a44b124561f544c229c0042cd0b91d055a33409.tar.zst
nix-3a44b124561f544c229c0042cd0b91d055a33409.zip
Add work VM and redo entire flake layout
Diffstat (limited to 'hosts/richese/disks.nix')
-rw-r--r--hosts/richese/disks.nix98
1 files changed, 98 insertions, 0 deletions
diff --git a/hosts/richese/disks.nix b/hosts/richese/disks.nix
new file mode 100644
index 0000000..9f05d48
--- /dev/null
+++ b/hosts/richese/disks.nix
@@ -0,0 +1,98 @@
+{
+ disko.devices = {
+ disk = {
+ sda = {
+ type = "disk";
+ device = "/dev/sda";
+ content = {
+ type = "gpt";
+ partitions = {
+ boot = {
+ size = "4M";
+ type = "EF02";
+ };
+ ESP = {
+ size = "1G";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "defaults" ];
+ extraArgs = [ "-n boot" ];
+ };
+ };
+ swap = {
+ size = "16G";
+ type = "8200";
+ content = {
+ type = "swap";
+ extraArgs = [ "-L swap" ];
+ };
+ };
+ rpool = {
+ size = "100%";
+ content = {
+ type = "zfs";
+ pool = "rpool";
+ };
+ };
+ };
+ };
+ };
+ };
+ zpool = {
+ rpool = {
+ type = "zpool";
+ rootFsOptions = {
+ acltype = "posixacl";
+ dnodesize = "auto";
+ xattr = "sa";
+ relatime = "on";
+ normalization = "formD";
+ encryption = "aes-256-gcm";
+ keyformat = "passphrase";
+ keylocation = "file:///tmp/data.keyfile";
+ compression = "on";
+ };
+ postCreateHook = ''
+ zfs set keylocation="prompt" rpool
+ '';
+ options = {
+ ashift = "12";
+ #autotrim = "on";
+ };
+ datasets = {
+ "local/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/";
+ };
+ "local/nix" = {
+ type = "zfs_fs";
+ options = {
+ atime = "off";
+ mountpoint = "legacy";
+ };
+ mountpoint = "/nix";
+ };
+ "user/home" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home";
+ };
+ "user/home/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/root";
+ };
+ "user/home/nipsy" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home/nipsy";
+ };
+ };
+ };
+ };
+ };
+}