aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/neptune/disks.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-12 00:03:55 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-12 00:03:55 -0800
commit7968deab695be4d5eaadfc81d2413f61d82ee777 (patch)
tree5912519fdc4eb07d26d48ee0e69c05d271c17347 /hosts/neptune/disks.nix
parent796fcbfd3b9c2de166ada6d317c6f041914e66ec (diff)
downloadnix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.gz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.bz2
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.lz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.xz
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.tar.zst
nix-7968deab695be4d5eaadfc81d2413f61d82ee777.zip
Add @neptune @saturn
Diffstat (limited to 'hosts/neptune/disks.nix')
-rw-r--r--hosts/neptune/disks.nix96
1 files changed, 96 insertions, 0 deletions
diff --git a/hosts/neptune/disks.nix b/hosts/neptune/disks.nix
new file mode 100644
index 0000000..52e8926
--- /dev/null
+++ b/hosts/neptune/disks.nix
@@ -0,0 +1,96 @@
+{
+ disko.devices = {
+ disk = {
+ nvme0n1 = {
+ type = "disk";
+ device = "/dev/nvme0n1";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ size = "1G";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "defaults" ];
+ extraArgs = [ "-nboot" ];
+ };
+ };
+ swap = {
+ size = "16G";
+ type = "8200";
+ content = {
+ type = "swap";
+ extraArgs = [ "-L swap" ];
+ };
+ };
+ rpool = {
+ size = "100%";
+ content = {
+ type = "zfs";
+ pool = "rpool";
+ };
+ };
+ };
+ };
+ };
+ };
+ zpool = {
+ rpool = {
+ type = "zpool";
+ rootFsOptions = {
+ acltype = "posixacl";
+ canmount = "off";
+ compression = "on";
+ dnodesize = "auto";
+ relatime = "on";
+ xattr = "sa";
+ };
+ options = {
+ ashift = "12";
+ autotrim = "on";
+ };
+ datasets = {
+ "local" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ };
+ "local/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/";
+ };
+ "local/nix" = {
+ type = "zfs_fs";
+ options = {
+ atime = "off";
+ mountpoint = "legacy";
+ };
+ mountpoint = "/nix";
+ };
+ "user" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ };
+ "user/home" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home";
+ };
+ "user/home/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/root";
+ };
+ "user/home/nipsy" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home/nipsy";
+ };
+ };
+ };
+ };
+ };
+}