aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/kaitain/disks.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-06-21 13:18:11 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-06-21 13:18:11 -0700
commit42951df89da73eb53959fde02014e8a63d56065e (patch)
tree46d4f06401eeba7662ecc7837f4827e86041aaeb /hosts/kaitain/disks.nix
parent89867e408dec0c3a48bbbaec2173ee8d140f2adc (diff)
downloadnix-42951df89da73eb53959fde02014e8a63d56065e.tar
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.gz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.bz2
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.lz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.xz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.zst
nix-42951df89da73eb53959fde02014e8a63d56065e.zip
Add new Virtualbox VM kaitain
Diffstat (limited to 'hosts/kaitain/disks.nix')
-rw-r--r--hosts/kaitain/disks.nix104
1 files changed, 104 insertions, 0 deletions
diff --git a/hosts/kaitain/disks.nix b/hosts/kaitain/disks.nix
new file mode 100644
index 0000000..c8bcd5c
--- /dev/null
+++ b/hosts/kaitain/disks.nix
@@ -0,0 +1,104 @@
+{
+ disko.devices = {
+ disk = {
+ sda = {
+ type = "disk";
+ device = "/dev/sda";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ size = "1G";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "defaults" ];
+ extraArgs = [ "-n boot" ];
+ };
+ };
+ swap = {
+ size = "16G";
+ type = "8200";
+ content = {
+ type = "swap";
+ extraArgs = [ "-L swap" ];
+ };
+ };
+ rpool = {
+ size = "100%";
+ content = {
+ type = "zfs";
+ pool = "rpool";
+ };
+ };
+ };
+ };
+ };
+ };
+ zpool = {
+ rpool = {
+ type = "zpool";
+ rootFsOptions = {
+ acltype = "posixacl";
+ canmount = "off";
+ compression = "on";
+ dnodesize = "auto";
+ encryption = "aes-256-gcm";
+ keyformat = "passphrase";
+ keylocation = "file:///tmp/data.keyfile";
+ #normalization = "formD"; # disabled due to previous issue: https://github.com/NixOS/nixpkgs/pull/86432
+ relatime = "on";
+ xattr = "sa";
+ };
+ postCreateHook = ''
+ zfs set keylocation="prompt" rpool
+ '';
+ options = {
+ ashift = "12";
+ #autotrim = "on";
+ };
+ datasets = {
+ "local" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ };
+ "local/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/";
+ };
+ "local/nix" = {
+ type = "zfs_fs";
+ options = {
+ atime = "off";
+ mountpoint = "legacy";
+ };
+ mountpoint = "/nix";
+ };
+ "user" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ mountpoint = "/home";
+ };
+ "user/home" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home";
+ };
+ "user/home/root" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/root";
+ };
+ "user/home/nipsy" = {
+ type = "zfs_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/home/nipsy";
+ };
+ };
+ };
+ };
+ };
+}