aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/ginaz/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-12 10:04:38 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-12 10:04:38 -0800
commit8328e393ce834ecb6038698d6649427ea1be4a0f (patch)
tree4f1d6c3c5f7108d6a4b7ea800f3c6127528f276f /hosts/ginaz/hardware-configuration.nix
parent80a6beccba107f0a728c038a79914e084ab097a7 (diff)
downloadnix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.gz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.bz2
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.lz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.xz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.zst
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.zip
Modularize disko everywhere
Diffstat (limited to 'hosts/ginaz/hardware-configuration.nix')
-rw-r--r--hosts/ginaz/hardware-configuration.nix67
1 files changed, 19 insertions, 48 deletions
diff --git a/hosts/ginaz/hardware-configuration.nix b/hosts/ginaz/hardware-configuration.nix
index 6a773e6..cbfda8a 100644
--- a/hosts/ginaz/hardware-configuration.nix
+++ b/hosts/ginaz/hardware-configuration.nix
@@ -13,57 +13,28 @@
boot.kernelModules = [ "kvm-amd" ];
boot.extraModulePackages = [ ];
- fileSystems."/" =
- { device = "rpool/local/root";
- fsType = "zfs";
+ hardware = {
+ bluetooth.enable = true;
+ #bluetooth.powerOnBoot = true;
+
+ graphics = {
+ enable = true;
+ extraPackages = with pkgs; [ nvidia-vaapi-driver ];
+ extraPackages32 = with pkgs.pkgsi686Linux; [ nvidia-vaapi-driver ];
};
- fileSystems."/boot" =
- { device = "/dev/disk/by-label/boot";
- fsType = "vfat";
- };
-
- fileSystems."/nix" =
- { device = "rpool/local/nix";
- fsType = "zfs";
- };
-
- fileSystems."/root" =
- { device = "rpool/user/home/root";
- fsType = "zfs";
- };
-
- fileSystems."/home/nipsy" =
- { device = "rpool/user/home/nipsy";
- fsType = "zfs";
- };
-
- swapDevices =
- [ { device = "/dev/disk/by-label/swap"; }
- ];
-
- hardware = {
- bluetooth.enable = true;
- #bluetooth.powerOnBoot = true;
-
- graphics = {
- enable = true;
- extraPackages = with pkgs; [ nvidia-vaapi-driver ];
- extraPackages32 = with pkgs.pkgsi686Linux; [ nvidia-vaapi-driver ];
- };
-
- nvidia = {
- modesetting.enable = true;
- open = true;
- package = config.boot.kernelPackages.nvidiaPackages.beta;
- prime = {
- amdgpuBusId = "PCI:4:0:0";
- nvidiaBusId = "PCI:1:0:0";
- offload = {
- enable = true;
- enableOffloadCmd = true;
- };
+ nvidia = {
+ modesetting.enable = true;
+ open = true;
+ package = config.boot.kernelPackages.nvidiaPackages.beta;
+ prime = {
+ amdgpuBusId = "PCI:4:0:0";
+ nvidiaBusId = "PCI:1:0:0";
+ offload = {
+ enable = true;
+ enableOffloadCmd = true;
};
};
};
+ };
}