aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/ginaz/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-04-13 15:52:28 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-04-13 15:52:28 -0700
commited68e6541c89e65ee654c1eb9ed9dce64ac1613e (patch)
tree5c0c3f2019dcec34d0050afee8f5c8f60b5d4473 /hosts/ginaz/default.nix
parent8f4ff719d0c17d294e7917eef418a4b13f7466b3 (diff)
downloadnix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar.gz
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar.bz2
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar.lz
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar.xz
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.tar.zst
nix-ed68e6541c89e65ee654c1eb9ed9dce64ac1613e.zip
Update ginaz to be heavily modular
Diffstat (limited to 'hosts/ginaz/default.nix')
-rw-r--r--hosts/ginaz/default.nix216
1 files changed, 9 insertions, 207 deletions
diff --git a/hosts/ginaz/default.nix b/hosts/ginaz/default.nix
index 9b306d1..97f14d9 100644
--- a/hosts/ginaz/default.nix
+++ b/hosts/ginaz/default.nix
@@ -11,163 +11,23 @@
zfs.devNodes = "/dev/disk/by-label";
};
- documentation.dev.enable = true;
- documentation.man.enable = true;
-
- environment.systemPackages = with pkgs; [
- bc
- bespokesynth
- binutils
- cardinal
- cargo
- conntrack-tools
- coreutils
- curl
- dmenu
- dict
- diffutils
- dig
- dmidecode
- easyeffects
- encfs
- enscript
- evince
- feh
- ffmpeg
- file
- findutils
- flac
- fldigi
- fluidsynth
- foot
- fortune
- fping
- gcc
- gcr
- geeqie
- geonkick
- #gimp-with-plugins
- gimp
- git
- go
- godot_4
- google-authenticator
- google-chrome
- gv
- helm
- i3
- i3status
- imagemagick
- inkscape
- inxi
- iotop
- ipcalc
- iperf
- iputils
- jq
- lame
- libreoffice
- libva-utils
- lilypond-unstable-with-fonts
- lshw
- lsof
- mame
- mariadb
- mednafen
- mednaffe
- mesa-demos
- mkvtoolnix
- mpv
- mutt
- netcat-openbsd
- nix-index
- nmap
- ntfs3g
- oath-toolkit
- openldap
- openssl
- (pass.withExtensions (ext: with ext; [pass-otp]))
- pass
- patchelf
- pavucontrol
- pciutils
- picom
- polkit_gnome
- polyphone
- poppler_utils
- powertop
- psmisc
- pv
- pwgen
- qemu_kvm
- qpwgraph
- qrencode
- qsynth
- radeontop
- rdesktop
- read-edid
- reaper
- recode
- rosegarden
- rustc
- samplv1
- sdrconnect
- sfizz
- sg3_utils
- signal-desktop
- speedtest-cli
- sqlite
- sshfs
- st
- stoken
- surge-XT
- sxiv
- synthv1
- sysstat
- tcpdump
- tigervnc
- traceroute
- tree
- tshark
- turbovnc
- unrar
- unzip
- usbutils
- vapoursynth
- vdpauinfo
- vim
- vlc
- vmpk
- vocproc
- vulkan-tools
- wavpack
- wget
- whois
- winetricks
- wineWowPackages.stagingFull
- wireguard-tools
- x11vnc
- x265
- xclip
- xdotool
- xorg.xdpyinfo
- xscreensaver
- xsnow
- yabridge
- yabridgectl
- yoshimi
- zig
- zip
- zynaddsubfx
- ];
+ #environment.systemPackages = with pkgs; [
+ # something
+ # somethingelse
+ #];
imports = [
./hardware-configuration.nix
../common/core
+ ../common/optional/db.nix
+ ../common/optional/dev.nix
+ ../common/optional/games.nix
../common/optional/google-authenticator.nix
../common/optional/pipewire.nix
+ ../common/optional/sdr.nix
../common/optional/services/openssh.nix
../common/optional/services/xorg.nix
+ ../common/optional/sound.nix
../common/optional/zfs.nix
../common/users/nipsy
../common/users/root
@@ -180,63 +40,5 @@
nftables.enable = true;
};
- programs.atop.enable = true;
- programs.firefox.enable = true;
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- };
- programs.iftop.enable = true;
- programs.mtr.enable = true;
- programs.nm-applet.enable = true;
- programs.steam.enable = true;
- programs.tmux.enable = true;
- programs.zsh.enable = true;
-
- security.polkit = {
- enable = true;
- extraConfig = ''
- polkit.addRule(function(action, subject) {
- if (
- subject.isInGroup("users")
- && (
- action.id == "org.freedesktop.login1.reboot" ||
- action.id == "org.freedesktop.login1.reboot-multiple-sessions" ||
- action.id == "org.freedesktop.login1.power-off" ||
- action.id == "org.freedesktop.login1.power-off-multiple-sessions"
- )
- )
- {
- return polkit.Result.YES;
- }
- })
- '';
- };
- services.blueman.enable = true;
- services.printing.enable = true;
- services.udev.extraRules = ''
- SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="2500",MODE:="0666"
- SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3000",MODE:="0666"
- SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3010",MODE:="0666"
- SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3020",MODE:="0666"
- SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3030",MODE:="0666"
- '';
-
- systemd = {
- user.services.polkit-gnome-authentication-agent-1 = {
- description = "polkit-gnome-authentication-agent-1";
- wantedBy = [ "graphical-session.target" ];
- wants = [ "graphical-session.target" ];
- after = [ "graphical-session.target" ];
- serviceConfig = {
- Type = "simple";
- ExecStart = "${pkgs.polkit_gnome}/libexec/polkit-gnome-authentication-agent-1";
- Restart = "on-failure";
- RestartSec = 1;
- TimeoutStopSec = 10;
- };
- };
- };
-
system.stateVersion = "23.11";
}