aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/darkstar/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
commit76137eca434293eaf138c95e285d128cae903119 (patch)
treee3d97cf14b4680b81be42ce9bbdfada5316a3f41 /hosts/darkstar/hardware-configuration.nix
parentd3fcdee236c02239de4117f731651c3c546f02e3 (diff)
downloadnix-76137eca434293eaf138c95e285d128cae903119.tar
nix-76137eca434293eaf138c95e285d128cae903119.tar.gz
nix-76137eca434293eaf138c95e285d128cae903119.tar.bz2
nix-76137eca434293eaf138c95e285d128cae903119.tar.lz
nix-76137eca434293eaf138c95e285d128cae903119.tar.xz
nix-76137eca434293eaf138c95e285d128cae903119.tar.zst
nix-76137eca434293eaf138c95e285d128cae903119.zip
Add host darkstar
Diffstat (limited to 'hosts/darkstar/hardware-configuration.nix')
-rw-r--r--hosts/darkstar/hardware-configuration.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/hosts/darkstar/hardware-configuration.nix b/hosts/darkstar/hardware-configuration.nix
new file mode 100644
index 0000000..3acea79
--- /dev/null
+++ b/hosts/darkstar/hardware-configuration.nix
@@ -0,0 +1,57 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ #(modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usbhid" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "rpool/local/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/efiboot/efi2" =
+ { device = "/dev/disk/by-label/ESP2";
+ fsType = "vfat";
+ options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
+ };
+
+ fileSystems."/nix" =
+ { device = "rpool/local/nix";
+ fsType = "zfs";
+ };
+
+ fileSystems."/root" =
+ { device = "rpool/user/home/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home/nipsy" =
+ { device = "rpool/user/home/nipsy";
+ fsType = "zfs";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-label/swap1"; }
+ { device = "/dev/disk/by-label/swap2"; }
+ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp116s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp117s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
+
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}