aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/darkstar/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
commit76137eca434293eaf138c95e285d128cae903119 (patch)
treee3d97cf14b4680b81be42ce9bbdfada5316a3f41 /hosts/darkstar/default.nix
parentd3fcdee236c02239de4117f731651c3c546f02e3 (diff)
downloadnix-76137eca434293eaf138c95e285d128cae903119.tar
nix-76137eca434293eaf138c95e285d128cae903119.tar.gz
nix-76137eca434293eaf138c95e285d128cae903119.tar.bz2
nix-76137eca434293eaf138c95e285d128cae903119.tar.lz
nix-76137eca434293eaf138c95e285d128cae903119.tar.xz
nix-76137eca434293eaf138c95e285d128cae903119.tar.zst
nix-76137eca434293eaf138c95e285d128cae903119.zip
Add host darkstar
Diffstat (limited to 'hosts/darkstar/default.nix')
-rw-r--r--hosts/darkstar/default.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/hosts/darkstar/default.nix b/hosts/darkstar/default.nix
new file mode 100644
index 0000000..f372762
--- /dev/null
+++ b/hosts/darkstar/default.nix
@@ -0,0 +1,58 @@
+{ config, pkgs, ... }: {
+ boot = {
+ initrd.kernelModules = [ "zfs" ];
+ kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ loader = {
+ efi = {
+ canTouchEfiVariables = true;
+ efiSysMountPoint = "/efiboot/efi1";
+ };
+ systemd-boot = {
+ enable = true;
+ extraInstallCommands = ''
+ mount -t vfat -o iocharset=iso8859-1 /dev/disk/by-label/ESP1 /efiboot/efi1
+ mount -t vfat -o iocharset=iso8859-1 /dev/disk/by-label/ESP2 /efiboot/efi2
+ cp -r /efiboot/efi1/* /efiboot/efi2
+ '';
+ };
+ timeout = 3;
+ };
+ supportedFilesystems = [ "zfs" ];
+ zfs.devNodes = "/dev/disk/by-label";
+ };
+
+ #environment.systemPackages = with pkgs; [
+ # something
+ # somethingelse
+ #];
+
+ imports = [
+ ./hardware-configuration.nix
+ ../common/core
+ #../common/optional/db.nix
+ #../common/optional/dev.nix
+ #../common/optional/ebooks.nix
+ #../common/optional/games.nix
+ #../common/optional/google-authenticator.nix
+ ../common/optional/misc.nix
+ #../common/optional/multimedia.nix
+ #../common/optional/pipewire.nix
+ #../common/optional/sdr.nix
+ ../common/optional/services/openssh.nix
+ #../common/optional/services/xorg.nix
+ #../common/optional/sound.nix
+ ../common/optional/zfs.nix
+ ../common/users/nipsy
+ ../common/users/root
+ ];
+
+ networking = {
+ hostId = "f9ca5efe";
+ hostName = "darkstar";
+ domain = "bitgnome.net";
+ #networkmanager.enable = true;
+ nftables.enable = true;
+ };
+
+ system.stateVersion = "23.11";
+}