aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/common/optional/services/dhcp.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-09 11:38:04 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-09 11:38:04 -0800
commit8ec087af30429f7d11e0bad9971193470a2f2f8f (patch)
treef150c2efee5e402353825528a40e6bfcb127c844 /hosts/common/optional/services/dhcp.nix
parent417aa85cba85453472e2dc22565ee8b7efba65d5 (diff)
downloadnix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar.gz
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar.bz2
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar.lz
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar.xz
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.tar.zst
nix-8ec087af30429f7d11e0bad9971193470a2f2f8f.zip
Rename file and update reference
Diffstat (limited to 'hosts/common/optional/services/dhcp.nix')
-rw-r--r--hosts/common/optional/services/dhcp.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/common/optional/services/dhcp.nix b/hosts/common/optional/services/dhcp.nix
new file mode 100644
index 0000000..6cfec9c
--- /dev/null
+++ b/hosts/common/optional/services/dhcp.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, ... }:
+{
+
+ environment.systemPackages = with pkgs; [
+ ipxe
+ ];
+
+ services.kea.dhcp4 = {
+ configFile = config.sops.secrets.kea-dhcp4_conf.path;
+ enable = true;
+ };
+
+ systemd.services.kea-dhcp4-server = {
+ serviceConfig = {
+ ExecStart = lib.mkForce ''
+ ${pkgs.kea}/bin/kea-dhcp4 -c ''${CREDENTIALS_DIRECTORY}/kea-dhcp4_conf
+ '';
+ LoadCredential = [ "kea-dhcp4_conf:${config.sops.secrets.kea-dhcp4_conf.path}" ];
+ };
+ };
+}