aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/arrakis/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-10-23 01:07:59 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-10-23 01:07:59 -0700
commit5352613027da11433f25d09d764ea406f2c786a2 (patch)
tree1f4909fda411a65d23e6da2d403d54af410f950c /hosts/arrakis/hardware-configuration.nix
parentd2b1b84dda74e414a46a7a2dac8ec5a0ccc9e1d1 (diff)
downloadnix-5352613027da11433f25d09d764ea406f2c786a2.tar
nix-5352613027da11433f25d09d764ea406f2c786a2.tar.gz
nix-5352613027da11433f25d09d764ea406f2c786a2.tar.bz2
nix-5352613027da11433f25d09d764ea406f2c786a2.tar.lz
nix-5352613027da11433f25d09d764ea406f2c786a2.tar.xz
nix-5352613027da11433f25d09d764ea406f2c786a2.tar.zst
nix-5352613027da11433f25d09d764ea406f2c786a2.zip
Add nVidia patches
Diffstat (limited to 'hosts/arrakis/hardware-configuration.nix')
-rw-r--r--hosts/arrakis/hardware-configuration.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hosts/arrakis/hardware-configuration.nix b/hosts/arrakis/hardware-configuration.nix
index 0983fac..bbf171f 100644
--- a/hosts/arrakis/hardware-configuration.nix
+++ b/hosts/arrakis/hardware-configuration.nix
@@ -1,7 +1,7 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ config, inputs, lib, nvidia-patch, pkgs, modulesPath, ... }:
+{ config, inputs, lib, pkgs, modulesPath, ... }:
let
package = config.boot.kernelPackages.nvidiaPackages.beta;
@@ -103,7 +103,7 @@ in
nvidia = {
modesetting.enable = true;
open = true;
- package = inputs.nvidia-patch.packages.x86_64-linux.nvidia-patch.patch-nvenc (inputs.nvidia-patch.packages.x86_64-linux.nvidia-patch.patch-fbc package);
+ package = pkgs.nvidia-patch.patch-nvenc (pkgs.nvidia-patch.patch-fbc package);
};
};
}