aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/arrakis/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-10-12 15:24:30 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-10-12 15:24:30 -0700
commita9402d76500eab999989599f559a1cbc1ecccfd8 (patch)
treea61ca731b4eb587121aa78952e80b27eeaf71c7b /hosts/arrakis/default.nix
parent7948eb742d024b738458683b1c38ce503c2901e7 (diff)
downloadnix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar.gz
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar.bz2
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar.lz
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar.xz
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.tar.zst
nix-a9402d76500eab999989599f559a1cbc1ecccfd8.zip
Fix bootloader options
Diffstat (limited to 'hosts/arrakis/default.nix')
-rw-r--r--hosts/arrakis/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/hosts/arrakis/default.nix b/hosts/arrakis/default.nix
index 8270bca..93c23c4 100644
--- a/hosts/arrakis/default.nix
+++ b/hosts/arrakis/default.nix
@@ -3,8 +3,16 @@
initrd.kernelModules = [ "zfs" ];
kernelPackages = pkgs.linuxPackages_6_10;
loader = {
- efi.canTouchEfiVariables = true;
- systemd-boot.enable = true;
+ efi = {
+ canTouchEfiVariables = true;
+ efiSysMountPoint = "/efiboot/efi1";
+ };
+ systemd-boot = {
+ enable = true;
+ extraInstallCommands = ''
+ ${pkgs.rsync}/bin/rsync -av --delete /efiboot/efi1/ /efiboot/efi2
+ '';
+ };
timeout = 3;
};
supportedFilesystems = [ "zfs" ];