aboutsummaryrefslogtreecommitdiffstats
path: root/home/don/common/core/bash.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2025-04-14 13:06:29 -0700
committerMark Nipper <nipsy@bitgnome.net>2025-04-14 13:06:29 -0700
commit508783d1875324811ad6ddd08f6a41739f0d9a87 (patch)
tree26ceb43e48e1bbf26ade54f007d9101419e22da2 /home/don/common/core/bash.nix
parent2b91916724acacd9b4076f6d81bbec2b7d981048 (diff)
downloadnix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar.gz
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar.bz2
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar.lz
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar.xz
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.tar.zst
nix-508783d1875324811ad6ddd08f6a41739f0d9a87.zip
Revert don@fangorn to bash
Diffstat (limited to 'home/don/common/core/bash.nix')
-rw-r--r--home/don/common/core/bash.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/home/don/common/core/bash.nix b/home/don/common/core/bash.nix
index 77f0cf4..7bfb808 100644
--- a/home/don/common/core/bash.nix
+++ b/home/don/common/core/bash.nix
@@ -3,8 +3,14 @@
enable = true;
enableCompletion = true;
shellAliases = {
- ll = "ls -alF --color=auto";
+ grep = "grep --color=auto";
+ ip = "ip -c=auto";
la = "ls -aF --color=auto";
+ ll = "ls -alF --color=auto";
+ lock = "xscreensaver-command -lock";
+ nix-list-derivations = "nix-store --query --requisites /run/current-system | cut -d- -f2- | sort | uniq";
+ nix-list-generations = "nixos-rebuild list-generations";
+ zgrep = "zgrep --color=auto";
};
};
}