diff options
author | Mark Nipper <nipsy@bitgnome.net> | 2024-11-11 19:05:02 -0800 |
---|---|---|
committer | Mark Nipper <nipsy@bitgnome.net> | 2024-11-11 19:05:02 -0800 |
commit | cb3885e72abaa985e0e1fd95f6e57382c7c343e7 (patch) | |
tree | 04fe914816b35de2a2e6a9d7eef2b1e296490492 /flake.nix | |
parent | 2f0664317ee6b6dd9bd05844582346b0b6fec1b8 (diff) | |
download | nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.gz nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.bz2 nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.lz nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.xz nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.zst nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.zip |
Add @uranus
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 14 |
1 files changed, 14 insertions, 0 deletions
@@ -156,6 +156,20 @@ } ]; }; + + uranus = nixpkgs.lib.nixosSystem rec { + specialArgs = { inherit inputs outputs; }; + modules = [ + ./hosts/uranus + home-manager.nixosModules.home-manager { + #home-manager.sharedModules = [ sops-nix.homeManagerModules.sops ]; + home-manager.users.root = import ./home/root/uranus.nix; + home-manager.users.nipsy = import ./home/nipsy/uranus.nix; + } + #sops-nix.nixosModules.sops + ]; + }; + }; overlays = import ./overlays {inherit inputs;}; |