aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-12 10:04:38 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-12 10:04:38 -0800
commit8328e393ce834ecb6038698d6649427ea1be4a0f (patch)
tree4f1d6c3c5f7108d6a4b7ea800f3c6127528f276f /flake.nix
parent80a6beccba107f0a728c038a79914e084ab097a7 (diff)
downloadnix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.gz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.bz2
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.lz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.xz
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.tar.zst
nix-8328e393ce834ecb6038698d6649427ea1be4a0f.zip
Modularize disko everywhere
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index bebe62e..f87cd07 100644
--- a/flake.nix
+++ b/flake.nix
@@ -55,6 +55,7 @@
arrakis = nixpkgs.lib.nixosSystem {
specialArgs = { inherit inputs outputs; };
modules = [
+ disko.nixosModules.disko
./hosts/arrakis
home-manager.nixosModules.home-manager {
home-manager.sharedModules = [ sops-nix.homeManagerModules.sops ];
@@ -68,6 +69,7 @@
darkstar = nixpkgs.lib.nixosSystem {
specialArgs = { inherit inputs outputs; };
modules = [
+ disko.nixosModules.disko
./hosts/darkstar
home-manager.nixosModules.home-manager {
home-manager.users.root = import ./home/root/darkstar.nix;
@@ -80,6 +82,7 @@
ginaz = nixpkgs.lib.nixosSystem rec {
specialArgs = { inherit inputs outputs; };
modules = [
+ disko.nixosModules.disko
./hosts/ginaz
home-manager.nixosModules.home-manager {
home-manager.sharedModules = [ sops-nix.homeManagerModules.sops ];
@@ -110,6 +113,7 @@
kaitain = nixpkgs.lib.nixosSystem rec {
specialArgs = { inherit inputs outputs; };
modules = [
+ disko.nixosModules.disko
./hosts/kaitain
home-manager.nixosModules.home-manager {
home-manager.users.root = import ./home/root/kaitain.nix;
@@ -164,6 +168,7 @@
richese = nixpkgs.lib.nixosSystem rec {
specialArgs = { inherit inputs outputs; };
modules = [
+ disko.nixosModules.disko
./hosts/richese
home-manager.nixosModules.home-manager {
home-manager.users.root = import ./home/root/richese.nix;