aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-05-03 00:10:05 -0700
commit76137eca434293eaf138c95e285d128cae903119 (patch)
treee3d97cf14b4680b81be42ce9bbdfada5316a3f41 /flake.nix
parentd3fcdee236c02239de4117f731651c3c546f02e3 (diff)
downloadnix-76137eca434293eaf138c95e285d128cae903119.tar
nix-76137eca434293eaf138c95e285d128cae903119.tar.gz
nix-76137eca434293eaf138c95e285d128cae903119.tar.bz2
nix-76137eca434293eaf138c95e285d128cae903119.tar.lz
nix-76137eca434293eaf138c95e285d128cae903119.tar.xz
nix-76137eca434293eaf138c95e285d128cae903119.tar.zst
nix-76137eca434293eaf138c95e285d128cae903119.zip
Add host darkstar
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 537b247..a8c1b60 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,6 +23,18 @@
outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, ... }: rec {
nixosConfigurations = {
+ darkstar = nixpkgs-unstable.lib.nixosSystem {
+ pkgs = pkgs-unstable;
+ system = "x86_64-linux";
+ modules = [
+ ./hosts/darkstar
+ home-manager-unstable.nixosModules.home-manager {
+ home-manager.users.root = import ./home/root/ginaz.nix;
+ home-manager.users.nipsy = import ./home/nipsy/ginaz.nix;
+ }
+ ];
+ };
+
ginaz = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
system = "x86_64-linux";