aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2025-05-20 12:51:21 -0700
committerMark Nipper <nipsy@bitgnome.net>2025-05-20 12:51:21 -0700
commit5b4e02cbd30d2d6062b66930b432787797b4ae22 (patch)
tree0d5f678ce7738414298dfb7edca83c56083d10d3 /flake.nix
parentf479404f2ecae66217405fe348141983def72631 (diff)
downloadnix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar.gz
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar.bz2
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar.lz
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar.xz
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.tar.zst
nix-5b4e02cbd30d2d6062b66930b432787797b4ae22.zip
Update environment.systemPackages syntax
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix165
1 files changed, 83 insertions, 82 deletions
diff --git a/flake.nix b/flake.nix
index 4775d84..17a1173 100644
--- a/flake.nix
+++ b/flake.nix
@@ -148,88 +148,89 @@
iso = nixpkgs.lib.nixosSystem {
modules = [
({ modulesPath, pkgs, ... }: {
- environment.systemPackages = with pkgs; [
- acl
- bash
- bc
- bzip2
- conntrack-tools
- coreutils
- cpio
- curl
- diffutils
- dig
- dmidecode
- elinks
- encfs
- ethtool
- expect
- file
- findutils
- fio
- fping
- git
- gnugrep
- gnupatch
- gnused
- gnutar
- gptfdisk
- gzip
- htop
- iotop
- ipcalc
- iperf
- iproute2
- iputils
- jq
- less
- lshw
- lsof
- lvm2
- moreutils
- nano
- netcat-openbsd
- nettools
- nmap
- ntfs3g
- openldap
- openssl
- p7zip
- parted
- pciutils
- procps
- progress
- psmisc
- pv
- pwgen
- recode
- rsync
- sg3_utils
- smartmontools
- socat
- speedtest-cli
- sqlite
- sshfs
- strace
- sysstat
- tcpdump
- tftp-hpa
- traceroute
- tree
- tshark
- unixtools.xxd
- unrar
- unzip
- usbutils
- util-linux
- vim
- wdiff
- wget
- whois
- wireguard-tools
- xz
- zip
- ];
+ environment.systemPackages = builtins.attrValues {
+ inherit (pkgs)
+ acl
+ bash
+ bc
+ bzip2
+ conntrack-tools
+ coreutils
+ cpio
+ curl
+ diffutils
+ dig
+ dmidecode
+ elinks
+ encfs
+ ethtool
+ expect
+ file
+ findutils
+ fio
+ fping
+ git
+ gnugrep
+ gnupatch
+ gnused
+ gnutar
+ gptfdisk
+ gzip
+ htop
+ iotop
+ ipcalc
+ iperf
+ iproute2
+ iputils
+ jq
+ less
+ lshw
+ lsof
+ lvm2
+ moreutils
+ nano
+ netcat-openbsd
+ nettools
+ nmap
+ ntfs3g
+ openldap
+ openssl
+ p7zip
+ parted
+ pciutils
+ procps
+ progress
+ psmisc
+ pv
+ pwgen
+ recode
+ rsync
+ sg3_utils
+ smartmontools
+ socat
+ speedtest-cli
+ sqlite
+ sshfs
+ strace
+ sysstat
+ tcpdump
+ tftp-hpa
+ traceroute
+ tree
+ tshark
+ unixtools.xxd
+ unrar
+ unzip
+ usbutils
+ util-linux
+ vim
+ wdiff
+ wget
+ whois
+ wireguard-tools
+ xz
+ zip
+ };
imports = [ (modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix") ];