aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-11 00:59:35 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-11 00:59:35 -0800
commit1df80e29d2110ef344a7af3499930d7ec12c615d (patch)
tree8223d3ed54bf5c47fe3f39cfc2f4beb5188a35c7 /flake.nix
parentedc175c5dc2bc20eaae974fde9dee1fb2a053299 (diff)
downloadnix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar.gz
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar.bz2
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar.lz
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar.xz
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.tar.zst
nix-1df80e29d2110ef344a7af3499930d7ec12c615d.zip
Add netboot image directly @arrakis
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 1db146a..903f70f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -130,6 +130,22 @@
#sops-nix.nixosModules.sops
];
};
+
+ netboot = nixpkgs.lib.nixosSystem {
+ modules = [
+ "${nixpkgs}/nixos/modules/installer/netboot/netboot-minimal.nix"
+ ({
+ #isoImage.squashfsCompression = "gzip -Xcompression-level 1";
+ nix.settings.experimental-features = [ "nix-command" "flakes" ];
+ users.users = {
+ nixos.openssh.authorizedKeys.keys = [ (builtins.readFile ./hosts/common/users/nipsy/keys/id_arrakis.pub) ];
+ root.openssh.authorizedKeys.keys = [ (builtins.readFile ./hosts/common/users/nipsy/keys/id_arrakis.pub) ];
+ };
+ })
+ ];
+ system = "x86_64-linux";
+ };
+
richese = nixpkgs.lib.nixosSystem rec {
specialArgs = { inherit inputs outputs; };
modules = [
@@ -140,7 +156,6 @@
}
];
};
-
};
overlays = import ./overlays {inherit inputs;};