aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-05-15 11:29:43 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-05-15 11:29:43 -0700
commit131141ba00a93de7be7491df3681cbd1f4c39099 (patch)
tree99700cc8456d1e161640558192dcf6f17c3a7eca /flake.nix
parent82325a1234180affdfaecd04686537ef2954a61b (diff)
downloadnix-131141ba00a93de7be7491df3681cbd1f4c39099.tar
nix-131141ba00a93de7be7491df3681cbd1f4c39099.tar.gz
nix-131141ba00a93de7be7491df3681cbd1f4c39099.tar.bz2
nix-131141ba00a93de7be7491df3681cbd1f4c39099.tar.lz
nix-131141ba00a93de7be7491df3681cbd1f4c39099.tar.xz
nix-131141ba00a93de7be7491df3681cbd1f4c39099.tar.zst
nix-131141ba00a93de7be7491df3681cbd1f4c39099.zip
Fix agenix configuration
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 6cbd2ad..2291950 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,10 +2,18 @@
description = "nipsy's NixOS configuration";
inputs = {
- agenix.url = "github:ryantm/agenix";
+ agenix = {
+ url = "github:ryantm/agenix";
+ inputs = {
+ nixpkgs.follows = "nixpkgs-unstable";
+ darwin.follows = "";
+ };
+ };
- disko.url = "github:nix-community/disko";
- disko.inputs.nixpkgs.follows = "nixpkgs-unstable";
+ disko = {
+ url = "github:nix-community/disko";
+ inputs.nixpkgs.follows = "nixpkgs-unstable";
+ };
home-manager-stable = {
url = "github:nix-community/home-manager/release-23.11";
@@ -27,6 +35,7 @@
nixosConfigurations = {
darkstar = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
+ specialArgs = inputs;
system = "x86_64-linux";
modules = [
./hosts/darkstar
@@ -40,6 +49,7 @@
ginaz = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
+ specialArgs = inputs;
system = "x86_64-linux";
modules = [
./hosts/ginaz