{ pkgs, ... }:
{
  environment.systemPackages = builtins.attrValues {
    inherit (pkgs)
      #other
      google-authenticator;
  };

  security.pam.services = {
    chfn.googleAuthenticator.enable = true;
    chsh.googleAuthenticator.enable = true;
    cups.googleAuthenticator.enable = true;
    lightdm.googleAuthenticator.enable = true;
    login.googleAuthenticator.enable = true;
    other.googleAuthenticator.enable = true;
    sshd.googleAuthenticator.enable = true;
    su.googleAuthenticator.enable = true;
    sudo.googleAuthenticator.enable = true;
    vlock.googleAuthenticator.enable = true;
    xlock.googleAuthenticator.enable = true;
    xscreensaver.googleAuthenticator.enable = true;
  };
}