aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/richese/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/richese/disks.nix')
-rw-r--r--hosts/richese/disks.nix18
1 files changed, 14 insertions, 4 deletions
diff --git a/hosts/richese/disks.nix b/hosts/richese/disks.nix
index 9f05d48..a0c8ed4 100644
--- a/hosts/richese/disks.nix
+++ b/hosts/richese/disks.nix
@@ -46,14 +46,15 @@
type = "zpool";
rootFsOptions = {
acltype = "posixacl";
+ canmount = "off";
+ compression = "on";
dnodesize = "auto";
- xattr = "sa";
- relatime = "on";
- normalization = "formD";
encryption = "aes-256-gcm";
keyformat = "passphrase";
keylocation = "file:///tmp/data.keyfile";
- compression = "on";
+ normalization = "formD";
+ relatime = "on";
+ xattr = "sa";
};
postCreateHook = ''
zfs set keylocation="prompt" rpool
@@ -63,6 +64,10 @@
#autotrim = "on";
};
datasets = {
+ "local" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ };
"local/root" = {
type = "zfs_fs";
options.mountpoint = "legacy";
@@ -76,6 +81,11 @@
};
mountpoint = "/nix";
};
+ "user" = {
+ type = "zfs_fs";
+ options.mountpoint = "none";
+ mountpoint = "/home";
+ };
"user/home" = {
type = "zfs_fs";
options.mountpoint = "legacy";