aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/richese/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/richese/default.nix')
-rw-r--r--hosts/richese/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/hosts/richese/default.nix b/hosts/richese/default.nix
index 865eef7..c476b60 100644
--- a/hosts/richese/default.nix
+++ b/hosts/richese/default.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, ... }: {
+{ config, inputs, lib, outputs, pkgs, ... }: {
boot = {
initrd.kernelModules = [ "zfs" ];
kernelPackages = pkgs.linuxPackages_6_10;
@@ -33,6 +33,16 @@
nftables.enable = true;
};
+ nixpkgs = {
+ config.allowUnfree = true;
+ hostPlatform = "x86_64-linux";
+ overlays = [
+ outputs.overlays.additions
+ outputs.overlays.modifications
+ outputs.overlays.stable-packages
+ ];
+ };
+
services.openssh.openFirewall = false;
services.xserver.videoDrivers = lib.mkForce [ "vmware" "virtualbox" "modesetting" ];