aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/kaitain/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kaitain/default.nix')
-rw-r--r--hosts/kaitain/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/hosts/kaitain/default.nix b/hosts/kaitain/default.nix
index b83a2c1..e90b77c 100644
--- a/hosts/kaitain/default.nix
+++ b/hosts/kaitain/default.nix
@@ -2,7 +2,11 @@
boot = {
initrd.kernelModules = [ "zfs" ];
kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
- loader.grub.device = "/dev/sda";
+ loader = {
+ efi.canTouchEfiVariables = true;
+ systemd-boot.enable = true;
+ timeout = 3;
+ };
supportedFilesystems = [ "zfs" ];
#zfs.devNodes = "/dev/disk/by-label";
};