aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/ginaz/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/ginaz/hardware-configuration.nix22
1 files changed, 16 insertions, 6 deletions
diff --git a/hosts/ginaz/hardware-configuration.nix b/hosts/ginaz/hardware-configuration.nix
index a4c479c..263ac54 100644
--- a/hosts/ginaz/hardware-configuration.nix
+++ b/hosts/ginaz/hardware-configuration.nix
@@ -46,12 +46,22 @@
bluetooth.enable = true;
#bluetooth.powerOnBoot = true;
- nvidia.prime = {
- amdgpuBusId = "PCI:4:0:0";
- nvidiaBusId = "PCI:1:0:0";
- offload = {
- enable = true;
- enableOffloadCmd = true;
+ graphics = {
+ enable = true;
+ extraPackages = with pkgs; [ nvidia-vaapi-driver ];
+ extraPackages32 = with pkgs.pkgsi686Linux; [ nvidia-vaapi-driver ];
+ };
+
+ nvidia = {
+ modesetting.enable = true;
+ open = true;
+ prime = {
+ amdgpuBusId = "PCI:4:0:0";
+ nvidiaBusId = "PCI:1:0:0";
+ offload = {
+ enable = true;
+ enableOffloadCmd = true;
+ };
};
};
};