aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/ginaz/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/ginaz/default.nix (renamed from ginaz/configuration.nix)135
1 files changed, 32 insertions, 103 deletions
diff --git a/ginaz/configuration.nix b/hosts/ginaz/default.nix
index 9310c2b..d5fa16c 100644
--- a/ginaz/configuration.nix
+++ b/hosts/ginaz/default.nix
@@ -1,27 +1,19 @@
-# Edit this configuration file to define what should be installed on
-# your system. Help is available in the configuration.nix(5) man page, on
-# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
-
-{ config, lib, pkgs, ... }: {
- imports =
- [ # Include the results of the hardware scan.
- ./hardware-configuration.nix
- ];
-
- boot.initrd.kernelModules = [ "amdgpu" "zfs" ];
- boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
- boot.loader.efi.canTouchEfiVariables = true;
- boot.loader.generationsDir.copyKernels = true;
- boot.loader.systemd-boot.enable = true;
- boot.supportedFilesystems = [ "zfs" ];
- boot.zfs.devNodes = "/dev/disk/by-label";
+{ config, inputs, pkgs, ... }: {
+ boot = {
+ initrd.kernelModules = [ "amdgpu" "zfs" ];
+ kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ loader = {
+ efi.canTouchEfiVariables = true;
+ systemd-boot.enable = true;
+ timeout = 3;
+ };
+ supportedFilesystems = [ "zfs" ];
+ zfs.devNodes = "/dev/disk/by-label";
+ };
documentation.dev.enable = true;
documentation.man.enable = true;
- environment.shells = with pkgs; [ zsh ];
- # List packages installed in system profile. To search, run:
- # $ nix search wget
environment.systemPackages = with pkgs; [
bc
bespokesynth
@@ -122,8 +114,7 @@
sshfs
st
stoken
- surge
- #surge-XT
+ surge-XT
sxiv
synthv1
sysstat
@@ -164,15 +155,26 @@
zynaddsubfx
];
- i18n.defaultLocale = "en_US.UTF-8";
+ imports = [
+ inputs.hardware.nixosModules.lenovo-yoga-7-14ARH7.amdgpu
- networking.hostId = "8425e349";
- networking.hostName = "ginaz";
- networking.networkmanager.enable = true;
- networking.nftables.enable = true;
+ ./hardware-configuration.nix
+ ../common/core
+ ../common/optional/google-authenticator.nix
+ ../common/optional/pipewire.nix
+ ../common/optional/services/openssh.nix
+ ../common/optional/services/xorg.nix
+ ../common/optional/zfs.nix
+ ../common/users/nipsy
+ ../common/users/root
+ ];
- nix.settings.experimental-features = [ "nix-command" "flakes" ];
- nixpkgs.config.allowUnfree = true;
+ networking = {
+ hostId = "8425e349";
+ hostName = "ginaz";
+ networkmanager.enable = true;
+ nftables.enable = true;
+ };
programs.atop.enable = true;
programs.firefox.enable = true;
@@ -187,20 +189,6 @@
programs.tmux.enable = true;
programs.zsh.enable = true;
- security.pam.services = {
- chfn.googleAuthenticator.enable = true;
- chsh.googleAuthenticator.enable = true;
- cups.googleAuthenticator.enable = true;
- lightdm.googleAuthenticator.enable = true;
- login.googleAuthenticator.enable = true;
- other.googleAuthenticator.enable = true;
- sshd.googleAuthenticator.enable = true;
- su.googleAuthenticator.enable = true;
- sudo.googleAuthenticator.enable = true;
- vlock.googleAuthenticator.enable = true;
- xlock.googleAuthenticator.enable = true;
- xscreensaver.googleAuthenticator.enable = true;
- };
security.polkit = {
enable = true;
extraConfig = ''
@@ -220,23 +208,7 @@
})
'';
};
- security.rtkit.enable = true;
-
services.blueman.enable = true;
- services.openssh = {
- enable = true;
- openFirewall = true;
- settings.PasswordAuthentication = false;
- settings.KbdInteractiveAuthentication = false;
- settings.PermitRootLogin = "yes";
- };
- services.pipewire = {
- enable = true;
- alsa.enable = true;
- alsa.support32Bit = true;
- pulse.enable = true;
- jack.enable = true;
- };
services.printing.enable = true;
services.udev.extraRules = ''
SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="2500",MODE:="0666"
@@ -245,29 +217,6 @@
SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3020",MODE:="0666"
SUBSYSTEM=="usb",ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1df7",ATTRS{idProduct}=="3030",MODE:="0666"
'';
- services.xserver = {
- displayManager.defaultSession = "xsession";
- displayManager.lightdm = {
- enable = true;
- extraSeatDefaults = ''greeter-hide-users=true'';
- };
- displayManager.session = [
- {
- manage = "desktop";
- name = "xsession";
- start = ''exec $HOME/.xsession'';
- }
- ];
- enable = true;
- libinput.enable = true;
- videoDrivers = [ "amdgpu" ];
- xkb.layout = "us";
- xkb.options = "caps:super,compose:ralt";
- };
- services.zfs.autoScrub.enable = true;
- services.zfs.trim.enable = true;
-
- system.stateVersion = "23.11";
systemd = {
user.services.polkit-gnome-authentication-agent-1 = {
@@ -285,25 +234,5 @@
};
};
- time.timeZone = "America/Los_Angeles";
-
- users.groups.nipsy.gid = 1000;
- users.users.nipsy = {
- isNormalUser = true;
- group = "nipsy";
- home = "/home/nipsy";
- description = "Mark Nipper";
- extraGroups = [ "wheel" "networkmanager" ];
- #packages = with pkgs; [
- # firefox
- # tree
- #];
- shell = pkgs.zsh;
- openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
- };
-
- users.users.root = {
- shell = pkgs.zsh;
- openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIbKppxX6GF88fAfXJZR4ZcPzwopi7TAy+v/dmWso+7f nipsy@arrakis.bitgnome.net" ];
- };
+ system.stateVersion = "23.11";
}