aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/darkstar/services.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/darkstar/services.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/hosts/darkstar/services.nix b/hosts/darkstar/services.nix
index 16a945d..67bfc1b 100644
--- a/hosts/darkstar/services.nix
+++ b/hosts/darkstar/services.nix
@@ -1,15 +1,16 @@
{
- networking.nftables.tables.ntp = {
- content = ''
- define int_if = enp116s0
-
- chain input {
- type filter hook input priority filter - 1; policy accept;
- iifname $int_if udp dport ntp accept # 123
- }
- '';
- enable = true;
- family = "inet";
+ networking = {
+ firewall = {
+ allowedTCPPorts = [
+ 53 # domain
+ ];
+ allowedUDPPorts = [
+ 53 # domain
+ ];
+ interfaces.enp116s0.allowedUDPPorts = [
+ 123 # ntp
+ ];
+ };
};
services.chrony = {