aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/darkstar/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/darkstar/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/hosts/darkstar/default.nix b/hosts/darkstar/default.nix
index 7eb3c62..c39f66a 100644
--- a/hosts/darkstar/default.nix
+++ b/hosts/darkstar/default.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }: {
+{ config, inputs, outputs, pkgs, ... }: {
boot = {
initrd.kernelModules = [ "zfs" ];
kernel.sysctl = {
@@ -80,6 +80,16 @@
#};
};
+ nixpkgs = {
+ config.allowUnfree = true;
+ hostPlatform = "x86_64-linux";
+ overlays = [
+ outputs.overlays.additions
+ outputs.overlays.modifications
+ outputs.overlays.stable-packages
+ ];
+ };
+
sops = {
age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
defaultSopsFile = ../secrets/darkstar.yaml;