aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/common/optional/services/dhcp.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/common/optional/services/dhcp.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/hosts/common/optional/services/dhcp.nix b/hosts/common/optional/services/dhcp.nix
index a91e27e..07adaeb 100644
--- a/hosts/common/optional/services/dhcp.nix
+++ b/hosts/common/optional/services/dhcp.nix
@@ -9,7 +9,7 @@
systemPackages = with pkgs; [
ipxe
- wol
+ tftp-hpa
];
};
@@ -19,10 +19,12 @@
enable = true;
};
- tftpd = {
- enable = true;
- path = "/etc/tftp";
- };
+ xinetd.services = [{
+ name = "tftp";
+ protocol = "udp";
+ server = "${pkgs.tftp-hpa}/sbin/in.tftpd";
+ serverArgs = "/etc/tftp";
+ }];
};
systemd.services.kea-dhcp4-server = {